关于多个蓝牙协议安全漏洞情况的通报

来源:国家信息安全漏洞库      时间:2017.09.22
[ 字体: 大:26 24 中:22 20 小:18 16 ]
转发至:
 

  近日,国家信息安全漏洞库(CNNVD)收到关于多个蓝牙协议安全漏洞的情况报送,攻击者可利用上述漏洞远程控制支持蓝牙的设备,获取其关键数据和访问权限,传播恶意软件。上述漏洞可影响启用蓝牙功能的设备,包括Android、Linux、iOS、Windows系统以及使用短距离无线通信技术的物联网设备等。

  目前,相关厂商已发布补丁修复此安全漏洞,由于涉及受影响产品数量较多,且漏洞利用工具“BlueBorne”已在互联网公布,此工具具有一定传播特性,可能同WannaCry勒索软件一样在全球范围迅速蔓延,对相当数量的公司和组织可造成较为严重的影响,因此建议受影响用户尽快升级补丁,并在修复完成之前尽量关闭“蓝牙”功能以避免此安全隐患。国家信息安全漏洞库(CNNVD)对上述系列漏洞进行验证并进行了跟踪分析,漏洞相关情况如下:

  一、漏洞简介

  多个受影响产品的相关漏洞情况如下:

  1、Linux kernel 缓冲区错误漏洞

  Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。Linux kernel 3.3-rc1版本至4.13.1版本中的L2CAP配置响应处理存在栈溢出漏洞(CNNVD-201709-480,CVE-2017-1000251)。远程攻击者可利用该漏洞执行代码。

  2、BlueZ SDP服务器信息泄露漏洞

  BlueZ是一套官方的Linux蓝牙协议栈。SDP server是其中的

  一个SDP服务器。BlueZ 5.46及之前的版本中的SDP服务器的SDP搜索属性请求的处理存在信息泄露漏洞(CNNVD-201709-481,CVE-2017-1000250)。远程攻击者可利用该漏洞获取蓝牙进程内存中的敏感信息。

  3、Apple iOS 安全漏洞

  Apple iOS是美国苹果(Apple)公司为移动设备所开发的一套操作系统。Apple iOS 7版本至9版本中的LEAP (Low Energy Audio Protocol)实现过程存在安全漏洞(CNNVD-201709-487,CVE-2017-14315)。该漏洞源于程序没有正确的验证音频命令。攻击者可利用该漏洞控制设备。

  4、Microsoft Windows 安全漏洞

  Microsoft Windows Server 2016等都是美国微软(Microsoft)公司发布的操作系统。Microsoft Windows Server 2016是一套服务器操作系统。Windows 8.1是一套个人电脑操作系统。Microsoft Windows中的Bluetooth栈存在欺骗漏洞(CNNVD-201709-499,CVE-2017-8628)。物理位置临近的攻击者可利用该漏洞实施中间人攻击,监控和读取流量。以下版本受到影响:Microsoft Windows Server 2016,Windows Server 2008 SP2,Windows RT 8.1,Windows 8.1,Windows 7 SP1,Microsoft Windows 10,Windows 10版本1511,Windows 10版本1607,Windows 10版本1703。

  5、Android信息泄露漏洞

  Android是美国谷歌(Google)公司和开放手持设备联盟(简称OHA)共同开发的一套以Linux为基础的开源操作系统。SDP(Service Discovery Protocol)server是其中的一个SDP服务器。Android中的SDP(Service Discovery Protocol)服务器存在信息泄露漏洞(CNNVD-201709-606、CVE-2017-0785)。攻击者可通过发送特制的请求利用该漏洞造成响应信息中的内存字节泄露,控制设备和蓝牙通信。以下版本受到影响:Android 4.4.4版本,5.0.2版本,5.1.1版本,6.0版本,6.0.1版本,7.0版本,7.1.1版本,7.1.2版本,8.0版本。

  6、Android信息泄露漏洞

  Android是美国谷歌(Google)公司和开放手持设备联盟(简称OHA)共同开发的一套以Linux为基础的开源操作系统。Android中的Bluetooth栈中的PAN配置文件存在信息泄露漏洞(CNNVD-201709-605、CVE-2017-0783)。攻击者可利用该漏洞实施中间人攻击,拦截并干预进出目标设备上的所有数据。以下版本受到影响:Android 4.4.4版本,5.0.2版本,5.1.1版本,6.0版本,6.0.1版本,7.0版本,7.1.1版本,7.1.2版本,8.0版本。

  7、Android安全漏洞

  Android是美国谷歌(Google)公司和开放手持设备联盟(简称OHA)共同开发的一套以Linux为基础的开源操作系统。Android中的Bluetooth Network Encapsulation Protocol(BNEP)服务存在远程代码执行漏洞(CNNVD-201709-603、CVE-2017-0781),该漏洞源于程序没有充分的验证授权,远程攻击者可利用该漏洞执行代码。以下版本受到影响:Android 4.4.4版本,5.0.2版本,5.1.1版本,6.0版本,6.0.1版本,7.0版本,7.1.1版本,7.1.2版本,8.0版本。

  8、Android安全漏洞

  Android是美国谷歌(Google)公司和开放手持设备联盟(简称OHA)共同开发的一套以Linux为基础的开源操作系统。Android中Bluetooth Network Encapsulation Protocol(BNEP)服务存在远程代码执行漏洞(CNNVD-201709-604、CVE-2017-0782)。远程攻击者可利用该漏洞获取设备的完全控制权。以下版本受到影响:Android 4.4.4版本,5.0.2版本,5.1.1版本,6.0版本,6.0.1版本,7.0版本,7.1.1版本,7.1.2版本,8.0版本。

  二、漏洞危害

  以上漏洞危害较为严重,影响多款产品的多个版本。

  1. 由于蓝牙进程在所有操作系统都具有最高权限,为此攻击者可利用上述漏洞获取最高权限,进而完全控制受影响设备,如网络间谍、数据窃取、勒索甚至创建大型僵尸网络。

  2.攻击者发起攻击时,其设备无需与目标设备进行配对,但需要具备两个前提条件:一是受影响设备的蓝牙处于开启状态,二是攻击者要尽可能靠近目标设备。

  三、修复措施

  目前,相关厂商官方已发布安全公告,并提供了产品的升级补丁对该漏洞进行修复。请受影响用户尽快更新补丁以消除漏洞影响,同时建议用户在不使用手机等设备时暂时“关闭”蓝牙设置,可临时缓解此安全风险。

  相关补丁链接如下:

  Microsoft Windows 安全漏洞(CNNVD-201709-499)

  https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8628

  Apple iOS 安全漏洞(CNNVD-201709-487)    

  https://www.apple.com/cn/

  BlueZ SDP服务器信息泄露漏洞(CNNVD-201709-481)

  https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=9e009647b14e810e06626dde7f1bb9ea3c375d09

  Linux kernel 缓冲区错误漏洞(CNNVD-201709-480)

  https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e860d2c904d1a9f38a24eb44c9f34b8f915a6ea3

  Android安全漏洞(CNNVD-201709-603、CNNVD-201709-604、CNNVD-201709-605、CNNVD-201709-606)  

  https://source.android.com/security/bulletin/2017-09-01

  本通报由CNNVD技术支撑单位——北京白帽汇科技有限公司提供支持。

  CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

  联系方式: cnnvd@itsec.gov.cn